Silence Deprecation Warnings for Ruby

Feature thumb ruby

The below instructions come with the caveat that the warnings that are displayed are printed out for a reason, so they shouldn't simply be ignored as you're building Ruby programs. However if you have the requirement to not show warnings, you can silence them with the following approach. Open the Bundler configuration file:

vim ~/.bundle/config

Add the line:

BUNDLE_MAJOR_DEPRECATIONS: "false"

Restart the terminal and the warnings should be silenced. Additional Bundler options are below: